MobileMe does not like Chrome (updated)

MobileMe + Chrome

Every year I struggle with the decision of whether to renew MobileMe (formerly .Mac, formerly iTools) or not. This year, for the first time, it’s a no brainer: The family pack covers myself, my two brothers, and my parents for a total of 8 Macs and 4 iPhones.

So I’ll pay. But it won’t be all happiness: I’ve been using Google’s new and excellent browser Chrome at work for months now. It’s stable, lightweight, simple, and fast. All of a sudden, MobileMe stopped working on Chrome. There is an interesting discussion on the topic at Apple’s Support Discussions. In summary, MobileMe started doing a browser check and it breaks if Chrome is the browser. If you fake the user-agent string, MobileMe works just fine.

C:\Users\me\AppData\Local\Google\Chrome\Application\chrome.exe –user-agent=”Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-en) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1″

This is very annoying because it proves that there is no technical reason (that anyone outside of Apple can gather) for MobileMe not working on Chrome. A big part of MobileMe is the “Cloud” part: You *should* be able to access it from any standards compliant browser. A big problem if it doesn’t work, especially for paid for service!

We will see how this pans out.

Update 1/13/2009: The shortcut above did not work for me, but I saw this today here and it did the job: MobileMe works in Google Chrome. Too bad you have to fake Google Chome’s identity. Instructions: create a shortcut to Google Chrome, right click on it and select Properties. Modify the target string to look like the one below, but substitute “mkirsch” with your user name. Hopefully it works for you as well.

“C:\Documents and Settings\mkirsch\Local Settings\Application Data\Google\Chrome\Application\chrome.exe”  –user-agent=”Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Version/3.1 Safari/525.19″

Update 1/13/2009: Looks like it’s fixed! Today I noticed that if you go to http://me.com in Google Chrome, you are shown the “Unsupported browser” screen. You can choose to ignore it and you are taken to full MobileMe. Just in time for my renewal :).

3 thoughts on “MobileMe does not like Chrome (updated)”

  1. mobileme was working fine in chrome for me until a few days ago (i use a pc at work, and it is my preferred browser, detest ie). no i cannot compose messages or reply to messages using chrome. really annoying, apple! get it together people.

Leave a Reply to bob Cancel reply